Classificação e filtragem

A classificação e a filtragem oferecem duas maneiras diferentes de personalizar a exibição de dados em sua planilha. Não é possível fazer as duas coisas ao mesmo tempo, então é melhor determinar com antecedência qual opção ajudará mais.

A classificação permite organizar parte ou a totalidade dos seus dados em ordem crescente ou decrescente. Observe que não é possível desfazer uma classificação após ela ter sido salva, portanto, certifique-se de que todas as linhas da planilha, incluindo as linhas pai em casos de hierarquia, estejam classificadas da maneira desejada antes de salvar.

Os filtros permitem exibir ou ocultar informações em sua planilha com base em critérios selecionados. Eles são úteis porque não alteram o layout geral da sua planilha. Você também pode salvar filtros e compartilhá-los com qualquer indivíduo com quem a planilha estiver compartilhada. Você pode até mesmo definir filtros padrão em sua planilha para que, quando os usuários com quem a planilha estiver compartilhada abrirem a planilha, eles vejam a mesma visualização.

Siga as instruções passo a passo para aprender como classificar as informações contidas em sua planilha.

Classificando linhas

Você pode Classificar um número selecionado de linhas em uma planilha ou todas as linhas de uma planilha para reorganizar os dados em ordem crescente ou decrescente.
 

Para classificar um determinado número de linhas em uma planilha:

 
  1. Em primeiro lugar, destaque as linhas mantendo pressionada a tecla [Shift] ou [Ctrl] e clicando nos números de linha que você deseja classificar.

  2. Clique na seta do menu suspenso  à direita do número da linha destacado e selecione Classificar linhas. O formulário Classificar aparecerá.

  3. Digite os critérios de classificação e clique em OK. As linhas selecionadas são classificadas pelos seus critérios.
 


Para classificar todas as linhas na planilha:

  1. Clique na seta de menu suspenso abaixo do cabeçalho de uma coluna Classificar linhas. O formulário Classificar aparecerá.
     
  2. Digite os critérios de classificação e clique em OK. As linhas selecionadas são classificadas pelos seus critérios.

Notas adicionais sobre classificação:
  • Classificando uma hierarquia: Se você’tiver criado subitens, eles serão classificados, mas permanecerão abaixo da linha pai. As linhas pai também serão ordenadas, mas seus subitens se moverão com elas.
  • Classificando uma lista suspensa: Se você classificar uma coluna que seja do tipo Lista suspensa, os itens serão classificados usando a ordem dos valores da lista suspensa. Clique duas vezes no cabeçalho’de uma coluna para exibir/editar esses valores.
  • Classificando valores Harvey Ball: Quando forem classificados em ordem crescente, os valores serão ordenados como Em branco > Vazio > Um Quarto > Metade >Três Quartos > Cheio.
  • Classificando os valores Vermelho - Amarelo - Verde: Quando classificados em ordem crescente, os valores serão ordenados como Em branco > Vermelho > Amarelo > Verde.
  • A classificação não estará disponível se Filtrar estiver aplicado a qualquer uma das colunas na planilha. Certifique-se de remover os filtros antes de classificar a planilha.
  • Aplicar uma classificação irá afetar as linhas existentes na planilha. Quando novas linhas forem adicionadas, será necessário aplicar uma nova classificação para colocá-las na em ordem.
  • Não há nenhuma maneira de remover ou desfazer uma classificação depois que a planilha for salva. Antes de salvar, verifique se as linhas em sua planilha estão na ordem desejada.
   

Siga as instruções passo a passo para aprender como criar e compartilhar filtros de planilhas.

Crie um filtro para mostrar ou ocultar dados

Com as devidas permissões, você pode criar filtros para uso próprio ou para compartilhar com os demais usuários. Precisa de uma visão geral rápida? Consulte Fundamentos básicos sobre filtros.

Crie um filtro de Usuário Atual compartilhado, por exemplo, para que todos os colaboradores da sua planilha possam visualizar rapidamente quais tarefas estão atribuídas a eles. Para mais informações sobre como criar um filtro de Usuário atual compartilhado, consulte o nosso artigo Visualizando as tarefas atribuídas a você.  

NOTA: a funcionalidade de Filtros compartilhados, aqui discutida, está incluída nos planos Executivo e Empresa. Para obter mais informações sobre planos e preços, entre elas quais recursos estão incluídos em cada plano, consulte nossa página de Preços.

Conteúdo do artigo:

Criando e usando filtros

Dicas para se trabalhar com condições

 

Permissões necessárias para se trabalhar com filtros

O que você pode fazer com os filtros em uma planilha depende sempre das permissões de compartilhamento que possui para a planilha em questão.

Atividades no filtro Visualizador Editor Proprietário ou Admin
Criar um "Filtro sem nome" Sim Sim Sim
Aplicar um filtro criado anteriormente Sim Sim Sim
Dar nome a um filtro para que ele possa ser reutilizado Não Sim Sim
Especificar se um filtro deve ser compartilhado com todos os colaboradores da planilha (plano de Equipe ou superior) Não Não Sim

Para mais informações sobre permissões de compartilhamento no âmbito de planilha, consulte o artigo Níveis de permissão de compartilhamento.


Criando e usando filtros

Filtrando dados com "Filtros sem nome"

O Filtro sem nome pode ser criado e usado por qualquer indivíduo que tenha acesso à planilha. Cada indivíduo que usa a planilha enxerga sua própria versão do filtro sem nome.

  1. Clique no menu Filtro e selecione Novo Filtro.

    O formulário Criar novo filtro será exibido.
     
  2. No formulário Criar novo filtro, em Mostrar linhas correspondentes, selecione as condições que deseja aplicar aos dados da planilha e clique em Aplicar para ver os resultados do filtro.

    O texto Filtro sem nome será exibido no menu de Filtros para indicar que seus dados estão sendo filtrados de acordo com as condições que você especificou.

Dando um nome ao filtro para salvá-lo ou compartilhá-lo

Se você possui permissões de editor (ou superior) em uma planilha, você pode dar nome a um filtro para salvá-lo para uso posterior. Se você tem permissões de Admin na planilha, você pode especificar para compartilhar o filtro com nome para que qualquer indivíduo da sua equipe que possua acesso à planilha também possa aplicar o filtro.

Formulário Novo filtro com 1 ao lado da caixa de Nome e 2 ao lado da caixa de seleção Compartilhar filtro

  1. Use a caixa Nome para dar um nome ao filtro.
  2. Marque a caixa de seleção Compartilhar filtro para disponibilizar o filtro a qualquer indivíduo que tenha acesso à planilha.

Para identificar os filtros que foram salvos por um Admin de planilha para serem compartilhados com os demais usuários, procure pelo indicador de compartilhamento Imagem de compartilhamento, localizado ao lado do nome do filtro.

Modificando um filtro

Depois de criar um filtro, você pode retornar e alterar os seus critérios (as condições que mostram ou ocultam informações da planilha) posteriormente. Veja como modificar um filtro:

  1. Aplique à planilha o filtro que deseja modificar (selecione-o no menu de Filtros).

    NOTA: se você não tiver permissões de Editor (ou superior), o único filtro que poderá modificar será o filtro sem nome.
     
  2. No menu de Filtros, selecione Editar filtro atual para abrir o formulário Editar filtro.

    DICA: o título do formulário exibirá o nome do filtro que você está prestes a modificar. Confira o título para se certificar de que esteja modificando o filtro correto.
     
  3. No formulário Editar filtro, atualize as condições conforme desejado e clique em Aplicar.

O filtro atualizado será aplicado à planilha.

Removendo um filtro

Para limpar um filtro (deixar de aplicá-lo à planilha), selecione Remover filtro alternância de filtro, à esquerda do nome do filtro.

Excluindo um filtro

Para excluir um filtro (removê-lo da planilha e do menu de filtros), selecione-o no menu de Filtros para aplicá-lo à planilha e depois escolha Excluir filtro atual.

Dicas para se trabalhar com condições

À medida que você especifica condições para seus filtros, você terá uma ideia melhor sobre como configurar os critérios que considera mais úteis. Veja a seguir algumas ideias para começar:

  • Altere a forma como os critérios são interpretados: para especificar se um filtro deverá usar todos os critérios definidos ou apenas um deles, clique no link ao lado da opção Mostrar linhas correspondentes para alternar entre todas as condições e pelo menos uma condição.
  • Filtre por células vazias: encontre linhas onde possam estar faltando dados usando a condição está vazio.
  • Inclua linhas pai: se a sua planilha usa hierarquia, você pode optar por configurar seu filtro para que inclua linhas pai, selecionando a caixa de seleção Incluir linhas pai. (Para mais informações sobre o uso de hierarquia nas planilhas, consulte o artigo de ajuda intitulado Usando hierarquias).
  • Filtre por tarefas atribuídas a você: crie um filtro de Usuário atual para permitir que os colaboradores vejam apenas as tarefas atribuídas a eles. Você pode encontrar mais detalhes sobre isso em nosso artigo intitulado Visualizando as tarefas atribuídas a você.
  • Use o critério de filtro de Linha para limitar com relação a caminho crítico, anexos, comentários e linhas bloqueadas. Consulte a seção abaixo para obter mais informações.

Filtre com relação ao caminho crítico, aos anexos, aos comentários e às linhas bloqueadas

Você pode usar o caminho crítico, os anexos, os comentários e as linhas bloqueadas como critério de filtro para mostrar ou ocultar certas linhas. O filtro Linha pode ajudar a limitar tarefas de caminho crítico, anexos e comentários nos quais você precisa trabalhar e linhas que estão bloqueadas para evitar que determinadas pessoas as editem.

Selecione Linha no primeiro campo suspenso para visualizar essas opções.

filtro de linha

Isolar seu campo crítico com um filtro

Se você definiu sua planilha para destacar linhas de caminho crítico, poderá aplicar um filtro com está no caminho crítico ou não está no caminho crítico como critério para exibir ou ocultar linhas de caminho crítico. As etapas sobre como habilitar o caminho crítico em sua planilha estão disponíveis em Monitorando o caminho crítico de um projeto.

Filtrar para encontrar rapidamente as linhas que têm anexos e comentários

Você pode criar um filtro com o critério de linha que mostra ou oculta as linhas que contêm anexos ou comentários. Use tem anexos ou tem comentários como um critério para isolar apenas as linhas para baixar anexos ou responder comentários a fim de comentar sequências de maneira mais rápida. O critério não tem anexos ou não tem comentários ocultará as linhas com anexos ou comentários. 

Disponibilizamos mais informações sobre trabalhar com anexos e comentários em suas planilhas nos seguintes artigos de ajuda:

Encontre linhas bloqueadas e desbloqueadas com um filtro

Use Linha está bloqueada ou Linha não está bloqueada como critério de filtro para mostrar ou ocultar linhas que podem somente ser editadas por pessoas com permissões de compartilhamento a nível de Admin em uma planilha. Isso pode ajudar as pessoas com permissões de Editor a restringirem as linhas que podem editar.

Mais informações sobre linhas bloqueadas podem ser encontradas em Bloqueando ou desbloqueando colunas e linhas.