Criar um filtro para mostrar ou ocultar dados

Com as permissões apropriadas, você pode criar vários filtros para seu próprio uso ou para compartilhar com os outros. Precisa de uma visão geral rápida? Consulte Fundamentos do filtro.

Crie um filtro de Usuário Atual compartilhado, por exemplo, para que todos os colaboradores em sua planilha possam ver rapidamente as tarefas atribuídas a eles. Para obter detalhes sobre a criação de um filtro de Usuário Atual compartilhado, confira o nosso artigo sobre a Visualização de suas tarefas atribuídas.

A funcionalidade de Filtros Compartilhados discutida aqui está incluída nos planos Executivo e Empresa. Para obter mais informações sobre planos e preços, como quais recursos estão incluídos em quais planos, consulte a nossa página de Preços.

Permissões necessárias para trabalhar com filtros

As ações que você poderá executar com os filtros em uma planilha dependerão das permissões de compartilhamento que você tem sobre aquela planilha.

Atividade de filtro Visualizador Editor Proprietário ou Admin
Criar um “Filtro sem nome” Sim Sim Sim
Aplicar um filtro já criado Sim Sim Sim
Dar nome a um filtro para que ele possa ser reutilizado Não Sim Sim
Especificar que um filtro deve ser compartilhado com todos os colaboradores da planilha (plano Equipe ou superior) Não Não Sim

Para obter mais informações sobre as permissões de compartilhamento no âmbito da planilha, confira Níveis de permissão de compartilhamento.


Criar e usar filtros

Filtrar dados com o “Filtro sem nome”

Se você tiver acesso a uma planilha, poderá criar um Filtro sem nome para visualizar os dados da planilha da maneira que for mais útil para você. A configuração do Filtro sem nome será exclusiva para você.

  1. Na barra de ferramentas, clique em Filtro > Novo Filtro.
    O formulário Criar novo filtro será exibido.
  2. No formulário Criar novo filtro, em Mostrar linhas correspondentes, selecione as condições que deseja aplicar aos dados da planilha e clique em Aplicar para ver os resultados do filtro.

    O Filtro sem nome será exibido no menu de Filtros para indicar que seus dados estão sendo filtrados de acordo com as condições especificadas.

DICA: Certos critérios só podem ser usados com tipos de dados específicos. Por exemplo, "contém" só pode ser usado com strings de texto e contatos, e "está entre" só pode ser usado com datas e números.

Dar nome a um filtro para salvar ou compartilhar

Se você tiver permissões de Editor ou superiores sobre uma planilha, será pode possível dar nome a um filtro para uso posterior. Se você tiver permissões de Admin sobre a planilha, você poderá especificar o compartilhamento do filtro salvo para que qualquer indivíduo da sua equipe que tenha acesso à planilha também possa aplicá-lo.

Apenas contas do plano Executivo, Empresa e Premier podem compartilhar um filtro com outros colaboradores.

Caixa de diálogo Criar Novo Filtro

  1. Utilize a caixa Nome para dar nome a um filtro.
  2. Selecione a caixa de seleção Compartilhar filtro para tornar o filtro disponível a qualquer indivíduo que tenha acesso à planilha.

Para identificar um filtro que foi salvo pelo Administrador da planilha para ser compartilhado com os outros, procure o indicador de compartilhamento Imagem de compartilhamento, ao lado do nome do filtro.

Modificar um filtro

Após criar um filtro, você pode retornar e alterar os critérios (as condições que mostram ou ocultam informações da planilha) posteriormente. Veja como modificar um filtro:

  1. Aplique o filtro que você deseja modificar à planilha (selecione-o no menu Filtro).

    NOTA: Se você não tiver permissões de Editor ou superiores, o único filtro que será capaz de modificar será o Filtro sem nome.
  2. No menu Filtro, passe o mouse sobre o nome do filtro e clique no ícone de Lápis ícone Editar.

    DICA: O título do formulário exibirá o nome do filtro que você está prestes a modificar. Verifique o título para checar se está modificando o filtro correto.
  3. No formulário Editar Filtro, atualize as condições conforme desejado e clique em Aplicar.

O filtro atualizado será aplicado à planilha.

Remover um filtro

Para limpar um filtro (deixar de aplicá-lo à planilha), selecione Desativar filtro.

Excluir um filtro

Para excluir um filtro (removê-lo da planilha e do menu), selecione-o no menu Filtro para aplicá-lo à planilha, depois selecione Excluir filtro atual.

Dicas para trabalhar com condições

À medida que você especifica condições para os seus filtros, você obtém uma noção melhor de como encontrar os critérios mais úteis. Veja a seguir algumas ideias para começar:

  • Alterar a forma como os critérios são interpretados: Para especificar se um filtro deve utilizar todos os critérios especificados ou apenas um deles, clique no link ao lado da opção Mostrar linhas correspondentes para alternar entre Todas as condições e Pelo menos uma condição.
  • Filtro para células em branco:Encontre as linhas em que os dados podem estar faltando usando a condição em branco.
  • Incluir linhas pai: Se a sua planilha usar hierarquia, você poderá optar por permitir que seu filtro inclua linhas pai marcando a caixa de seleção Incluir linhas pai. (Para obter mais informações sobre o uso de hierarquia em planilhas, confira o artigo de ajuda intitulado Usando hierarquia).
  • Filtrar por tarefas atribuídas a você:Crie um filtro de Usuário Atual para permitir que os colaboradores vejam apenas as tarefas atribuídas a eles mesmos. Você pode encontrar detalhes sobre isso no nosso artigo sobre Visualização das tarefas atribuídas a você.
  • Use os critérios de filtro de linha para restringir o caminho crítico, os anexos, os comentários e as linhas bloqueadas. Consulte a seção abaixo para obter mais informações.

Filtrar por caminho crítico, anexos, comentários e linhas bloqueadas

Você pode usar o caminho crítico, os anexos, os comentários e as linhas bloqueadas como critérios de filtro para mostrar ou ocultar determinadas linhas. Os critérios de filtro de linha podem ajudar você a restringir as tarefas do caminho crítico, os anexos e os comentários sobre os quais você precisa agir, e as linhas que estão bloqueadas para evitar a edição para certas pessoas.

Selecione Linha no primeiro campo suspenso para ver essas opções.

Caixa de diálogo Filtro de Linha com o menu suspenso aberto

Isole seu caminho crítico com um filtro

Se você configurou a planilha para destacar as linhas do caminho crítico, será possível aplicar um filtro com a opção pertence ao caminho crítico ou não pertence ao caminho crítico como o critério para exibir ou ocultar as linhas do caminho crítico. As etapas para habilitar o caminho crítico da sua planilha estão disponíveis em Acompanhando o caminho crítico de um projeto.

Filtro para encontrar rapidamente linhas que contenham anexos e comentários

Você pode criar um filtro com critérios de Linha que mostrem ou ocultem as linhas que contêm anexos ou comentários. Use tem anexos ou tem comentários como critério para isolar apenas as linhas para baixar anexos ou responder a tópicos de comentários mais rapidamente. Os critérios não tem anexos ou não tem comentários ocultarão as linhas com anexos ou comentários.

Mais informações sobre como trabalhar com anexos e comentários em suas planilhas estão disponíveis nos seguintes artigos de ajuda:

Encontre as linhas bloqueadas e desbloqueadas com um filtro

Use os critérios de filtro Linha bloqueada ou Linha não bloqueada para mostrar ou ocultar as linhas que só podem ser editadas por pessoas com permissões de compartilhamento de Admin sobre uma planilha. Isso pode ajudar as pessoas com permissões de Editor a restringir as linhas que eles têm permissão para editar.

Mais informações sobre linhas bloqueadas podem ser encontradas em Bloqueando ou Desbloqueando Colunas e Linhas.