Ordinamento e filtraggio

La funzione di ordinamento e filtraggio offre due modi diversi per personalizzare la visualizzazione dei dati nel tuo foglio. Non è possibile effettuare entrambe le operazioni contemporaneamente, pertanto è consigliabile stabilire in anticipo quale opzione sia più utile.

L'ordinamento ti consente di organizzare tutti i dati o parte di essi in ordine ascendente o discendente. Tieni presente che non puoi annullare un ordinamento dopo averlo salvato, pertanto devi assicurarti che tutte le tue righe nel foglio, incluse le righe madri nella gerarchia, siano ordinate nel modo che desideri prima di salvarle.

I filtri ti consentono di mostrare o nascondere le informazioni nel tuo foglio in base a criteri selezionati. Sono utili perché non cambiano il layout generale del tuo foglio. Puoi anche salvare i filtri e condividerli con chiunque sia condiviso nel foglio. È anche possibile impostare filtri predefiniti sul tuo foglio in modo che, quando gli utenti condivisi aprono quel foglio, possono ottenere la stessa visualizzazione.

Segui le istruzioni dettagliate per imparare e ordinare le informazioni nel tuo foglio.

Ordinamento delle righe

Puoi Ordinare un determinato numero di righe in un foglio oppure tutte le righe in un foglio per riorganizzare i dati in ordine crescente o decrescente.
 

Per ordinare un determinato numero di righe su un foglio:

 
  1. Per prima cosa, evidenzia le righe tenendo premuto il tasto [Maiusc] o [Ctrl] e clicca sui numeri di riga che desideri ordinare.

  2. Clicca sulla freccia a discesa  a destra del numero di una qualsiasi riga evidenziata e seleziona Ordina righe. Viene visualizzato il modulo Ordina.

  3. Inserisci i criteri di ordinamento, quindi clicca su OK. Le righe selezionate vengono ordinate in base ai tuoi criteri.
 


Per ordinare tutte le righe nel foglio:

  1. Clicca sulla freccia a discesa sotto l'intestazione di colonna e seleziona Ordina righe. Viene visualizzato il modulo Ordina.
     
  2. Inserisci i criteri di ordinamento, quindi clicca su OK. Le righe selezionate vengono ordinate in base ai tuoi criteri.

Note aggiuntive sull'ordinamento:
  • Ordinamento di una gerarchia:Se hai creato delle voci secondarie, queste verranno ordinate, ma mantenute al di sotto della loro riga madre. Anche le righe madre vengono ordinate e le loro voci secondarie si spostano con loro.
  • Ordinamento di un elenco a discesa: se esegui l'ordinamento su una colonna di tipo Elenco a discesa, le voci vengono ordinate utilizzando l'ordine dei valori dell'elenco a discesa. Fai doppio clic su un'intestazione di colonna per visualizzare o modificare questi valori.
  • Ordinare i valori delle Sfere di Harvey: quando sono disposti in ordine crescente, i valori sono ordinati come Vuoto > Quarto > Metà > Tre quarti > Pieno.
  • Ordinare i valori Rosso-Giallo-Verde: quando sono disposti in ordine crescente, i valori sono ordinati come Vuoto > Rosso > Giallo > Verde.
  • L'ordinamento non è disponibile se un Filtroè applicato una qualsiasi colonna nel foglio. Accertati di rimuovere i filtri prima di ordinare il foglio.
  • L'applicazione di un ordinamento influisce sulle righe esistenti nel foglio. Quando vengono aggiunte nuove righe, per incorporarle deve essere applicato un nuovo ordinamento.
  • Non è possibile rimuovere o annullare un ordinamento dopo che il foglio è stato salvato. Prima di salvare, assicurati che le righe nel foglio siano ordinate come desideri.
   

Segui queste istruzioni dettagliate per imparare a creare e a condividere i filtri del foglio.

Creare un filtro per mostrare o nascondere i dati

Con le autorizzazioni appropriate, puoi creare filtri per uso personale o per condividerli con altri. Hai bisogno di una rapida panoramica? Vedi Elementi base del filtro.

Crea un filtro di Utente corrente condiviso per, ad esempio, permettere a tutti i collaboratori sul foglio di visualizzare rapidamente le attività a loro assegnate. Per i dettagli sulla creazione di un filtro di Utente corrente condiviso, leggi il nostro articolo sulla Visualizzazione delle attività assegnate.  

NOTA: la funzionalità Filtri condivisi qui discussa è inclusa per i piani Business e Aziendale. Per ulteriori informazioni circa i piani e i prezzi, comprese le funzioni incluse a seconda dei diversi piani, si prega di vedere la nostra pagina Prezzi.

In questo articolo:

Creare e utilizzare i filtri

Consigli per lavorare con le condizioni

 

Autorizzazioni richieste per lavorare con i ifiltri

Le operazioni che possono essere eseguite in un foglio dipendono dalle autorizzazione della condivisione per il foglio.

Attività del filtroLettoreEditorProprietario o Amministratore
Crea un "Filtro senza nome"
Applica un filtro già creato
Assegna un nome a un filtro per poterlo riutilizzareNo
Specifica che il filtro deve essere condiviso con tutti i collaboratori (piano Team o superiore)NoNo

Per ulteriori informazioni sulle autorizzazioni di condivisione a livello di foglio, vedere Livelli di condivisione delle autorizzazioni.


Creare e utilizzare i filtri

Filtrare i dati con “Filtro senza nome”

Il Filtro senza nome può essere creato e utilizzato da chiunque abbia accesso al foglio. Ciascuna persona che usa il foglio visualizzerà la propria versione del Filtro senza nome.

  1. Fai clic sul menu Filtro e seleziona Nuovo filtro.

    Viene visualizzato il modulo Crea nuovo filtro.
     
  2. Nel modulo Crea nuovo filtro, in Mostra righe che corrispondono, seleziona le condizioni che vuoi applicare ai dati nel foglio e fai clic su Applica per vedere i risultati del filtro.

    Filtro senza nome apparirà nel menu Filtro per indicare che i dari vengono filtrati in base alle condizioni specificate.

Assegnare un nome a un filtro per salvarlo e condividerlo

Se disponi di autorizzazioni di Editor o superiori su un foglio puoi assegnare un nome al filtro per salvarlo per un uso futuro. Se disponi di autorizzazioni di Amministratore, puoi spcificare la condivisione del filtro con nome, in modo che chiunque nel team che abbia accesso al foglio possa applicare il filtro.

Modulo Nuovo filtro con 1 accanto alla casella Nome e 2 accanto alla casella di controllo Condividi filtro

  1. Usa la casella Nome per assegnare un nome al filtro.
  2. Seleziona la casella di controllo Condividi filtro per rendere disponibile il filtro a chiunque abbia accesso al foglio.

Per identificare un filtro con un Amministratore di foglio ha salvato per la condivisione con altri, individua l'indicatore di condivisione Condivisione di un'immagineaccanto al nome del filtro.

Modificare un filtro

Dopo aver creato un filtro, puoi sempre tornare indietro e modificare i criteri (le condizioni che mostrano o nascondono le informazioni nel foglio) successivamente. Ecco come modificare un filtro:

  1. Applica il filtro che vuoi modificare al foglio (selezionalo dal menu Filtro).

    NOTA: se non disponi di autorizzazioni di Editor o superiori, l'unico filtro che puoi modificare è il Filtro senza nome.
     
  2. Dal menu Filtro, seleziona Modifica filtro corrente per aprire il modulo Modifica filtro.

    SUGGERIMENTO: il titolo del modulo visualizza il nome del filtro che stai per modificare. Verifica il titolo per assicurarti che stai modificando il filtro corretto.
     
  3. Nel menu Modifica filtro, aggiorna le condizioni come desideri e fai clic su Applica.

Il filtro aggiornato sarà applicato al foglio.

Rimuovere un filtro

Per annullare un filtro (non applicarlo più al foglio), seleziona Rimuovi filtro commutazione filtro a sinistra del nome filtro.

Eliminare un filtro

Per eliminare un filtro (rimuoverlo dal foglio e dal menu), selezionalo dal menu Filtro per applicarlo al foglio e poi seleziona Elimina filtro corrente.

Consigli per lavorare con le condizioni

Quando specifichi le condizioni per i filtri, decidi come impostare i criteri che ritieni più utili. Ecco alcune idee per iniziare:

  • Modifica dell'interpretazione dei criteri: per specificare che un filtro usa tutti i criteri specificati o solo un criterio, fai clic sul link accanto a Mostra rige che corrispondono per alternare tutte le condizioni e almeno una condizione.
  • Filtri per celle vuote: trova le righe in cui i dati potrebbero mancare utilizzando la condizione is blank .
  • Includi righe madre: se il foglio utilizza una gerarchia, puoi scegliere che il filtro includa le righe madre selezionando la casella di controllo Includi righe madre. (Per ulteriori informazioni sull'utilizzo della gerarchi nei foglio, vedere l'articolo Utilizzo della gerarchia).
  • Filtro per attività assegnate a te: Crea un filtro Utente corrente per consentire ai collaboratori di vedere solo le attività che sono assegnate a loro. Puoi trovare i dettagli nell'articolo Visualizzazione delle attività assegnate.
  • Usa i criteri di filtro Riga per porre la limitazione su percorso critico, allegati, commenti e righe bloccate. Per ulteriori informazioni, vedi la sezione seguente.

Filtro su Percorso critico, Allegati, Commenti e Righe bloccate

Puoi utilizzare il percorso critico, gli allegati, i commenti e le righe bloccate come criteri di filtro per mostrare o nascondere determinate righe. Il criterio di filtro Riga permette di porre limitazioni sulle attività di percorso critico, allegati e commenti sui cui devi agire e sulle righe che sono bloccate per evitare che vengano modificate da determinate persone.

Seleziona Riga nel primo campo a discesa per visualizzare queste opzioni.

filtro riga

Isolare il tuo percorso critico con un filtro

Se hai configurato il tuo foglio in modo che vengano evidenziate le righe di percorso critico, puoi applicare un filtrocon è sul percorso critico o non è sul percorso critico come criterio per visualizzare o nascondere le righe del percorso critico. I passi su come abilitare il percorso critico nel tuo foglio sono disponibili in Monitoraggio del percorso critico di un progetto.

Filtro per trovare facilmente le righe che dispongono di allegati o commenti

Puoi creare un filtro con il criterio Riga che mostra o nasconde le righe contenenti allegati o commenti. Usa contiene allegati o contiene commenti come criteri per isolare solo le righe per scaricare gli allegati o rispondere a thread di commenti più rapidamente. I criteri non contiene allegati o non contiene commenti nasconderanno le righe con allegati o commenti. 

Ulteriori informazioni su come lavorare con allegati e commenti nei tuoi fogli sono disponibili nei seguenti articoli del centro assistenza:

Trovare righe bloccate e sbloccate con un filtro

Usa Riga bloccata o Riga non bloccata come criteri di filtro per mostrare o nascondere le righe che possono essere modificate solo dalle persone con autorizzazione di condivisione come amministratore su un foglio. Ciò permette alle persone con autorizzazioni di Editor di visualizzare le righe che sono autorizzati a modificare.

Per ulteriori informazioni sulle righe bloccate, vedi Bloccare o sbloccare le colonne e le righe.