Exporter une feuille ou un rapport

S’applique à

Smartsheet
  • Pro
  • Business
  • Enterprise

Dans l’application Smartsheet, vous pouvez exporter toute feuille ou rapport dans les formats suivants :

  • Microsoft Excel
  • Image (PNG) (Diagramme de Gantt uniquement)
  • Google Sheets
  • Microsoft Project (Diagramme de Gantt uniquement)
  • PDF

Après l’export d’une feuille ou d’un rapport, votre navigateur l’enregistre sur votre ordinateur. Le fichier exporté sera stocké dans un dossier en fonction des paramètres de votre navigateur.

Toutefois, votre export est incomplet. Les lignes de regroupement et récapitulatives sont exclues et les pièces jointes ne sont pas considérées. Pour inclure les pièces jointes, créez plutôt une sauvegarde de la feuille.

Pour localiser rapidement le fichier exporté, ouvrez le dossier Téléchargements de votre navigateur. Utilisez le raccourci clavier Ctrl + J sous Windows ou Commande + Option + L sous MacOS.

Utilisez Envoyer en tant que pièce jointe pour générer des exports récurrents

Pour envoyer par e-mail, à vous-même ou à d’autres personnes, une version PDF ou Excel de votre feuille ou rapport selon un programme récurrent, consultez les articles d’aide suivants :


Exporter vers Microsoft Excel

Pour exporter une feuille ou un rapport à partir de Smartsheet et l’utiliser dans Microsoft Excel, sélectionnez FichierExporter > Exporter vers Excel.

La façon dont les données exportées apparaissent dans Excel peut varier par rapport à Smartsheet. Voici une liste des principales différences :

  • Les diagrammes de Gantt sont exclus :Excel ne prend pas en charge le format Diagramme de Gantt. L’export d’un diagramme de Gantt vers Excel ne contient que la liste des tâches sur laquelle il est basé.
  • Les formules ne sont pas conservées :En raison des différences de syntaxe des formules entre Excel et Smartsheet, les formules ne sont pas conservées lors de l’export.

Pour contourner ce problème, supprimez le signe égal au début des formules pour les enregistrer en tant que texte, puis enregistrez la feuille. Lorsque vous rouvrez le fichier Excel, vous pouvez rajouter le signe égal et adapter la syntaxe des formules pour qu’elles fonctionnent dans Excel.

  • Les commentaires apparaissent dans un onglet séparé :Vous trouverez les commentaires dans le deuxième onglet du classeur exporté.
  • Les rapports sont limités à 20 000 lignes :Si votre rapport comporte plus de 20 000 lignes, vous pouvez en créer plusieurs qui en comportent moins et les exporter dans des fichiers Excel distincts. Pour plus d’informations sur l’utilisation des rapports, consultez Création de rapports.

Si vous avez trié votre rapport, vous pouvez exporter moins de 20 000 lignes.

  • Tous les types de colonnes ne sont pas pris en charge dans Excel :Excel ne prend pas en charge les colonnes de type Liste déroulante, Liste des contacts, Case à cocher et Symboles (par exemple, les sphères de Harvey, etc.) . Lorsque vous exportez des feuilles qui utilisent ces types de colonnes, seules les valeurs en texte sont exportées. Les valeurs dans les colonnes de type booléen (par exemple, Case à cocher) sont exportées comme Vrai ou Faux, selon l’état de l’élément dans la cellule.

Exporter au format image (PNG)

Pour exporter une feuille ou un rapport contenant un diagramme de Gantt au format PNG, procédez de la façon suivante :

  1. Ouvrez la feuille que vous souhaitez exporter.
  2. Dans la barre d’outils, basculez la feuille ou le rapport en Mode Gantt.
  3. Sélectionnez Fichier > Exporter > Exporter le diagramme de Gantt dans une image (PNG).
  4. Dans la section Sélection du formulaire Exporter le diagramme de Gantt dans une image (PNG), choisissez d’exporter la totalité de la feuille entière ou les lignes sélectionnées.
    • Si l’option Lignes sélectionnées n’est pas disponible, fermez le formulaire Exporter le diagramme de Gantt dans une image (PNG), sélectionnez les lignes à imprimer, et rouvrez le formulaire.
  5. Dans la section Options, sélectionnez les colonnes à inclure dans l’image.
    • Par défaut, seule la colonne principale est incluse, mais vous pouvez cliquer sur le nom de la Colonne principale ou sur le bouton Modifier pour inclure d’autres colonnes.

Personnaliser la période du calendrier imprimé dans votre export d’images

Si vous utilisez une plage de dates personnalisée, la durée affichée dépend de votre choix d’affichage du calendrier. Prenons l’exemple suivant : dans le formulaire Paramètres du projet, vous définissez l’En-tête principal de votre affichage du calendrier sur Années. Vous avez également choisi le 1er mars comme date de début et le 30 juin comme date de fin. Le PDF affichera une année entière en raison de votre choix de calendrier.

Pour réduire la période du calendrier imprimé, dans l’onglet Affichage du calendrier du formulaire Paramètres du projet, changez En-tête principal en Trimestres ou Semaines. Pour plus d’informations, consultez Modifier les paramètres d’interdépendance et de Gantt.


Exporter vers une feuille Google Sheet

Pour exporter une feuille ou un rapport à partir de Smartsheet vers Google Sheets, sélectionnez FichierExporter > Exporter vers Google Sheets.

Comme pour les fichiers exportés dans Excel, les fichiers exportés vers Google Sheets n’apparaîtront pas exactement comme dans Smartsheet. Voici une liste des principales différences :

  • Les diagrammes de Gantt sont exclus : Google Sheets ne prend pas en charge le format Diagramme de Gantt. L’export d’un diagramme de Gantt vers Google ne contient que la liste des tâches.
  • Tous les types de colonnes ne sont pas pris en charge dans Google Sheets : À l’instar d’Excel, Google Sheets ne prend pas en charge les colonnes de type Liste déroulante, Liste des contacts, Case à cocher et Symboles (par exemple, les sphères de Harvey, etc.) . Lorsque vous exportez des feuilles qui utilisent ces types de colonnes, seules les valeurs en texte sont exportées. Les valeurs dans les colonnes booléennes (par exemple, Case à cocher) sont exportées comme Vrai ou Faux, selon l’état de l’élément dans la cellule.
  • Les formules des fichiers ne sont pas conservées lors de l’export : La syntaxe des formules Smartsheet diffère de celle de Google Sheets. 

Pour contourner ce problème, supprimez le signe égal au début des formules pour les enregistrer en tant que texte, puis enregistrez la feuille. Lorsque vous rouvrez la feuille Google Sheets, vous pouvez rajouter ce signe égal et adapter la syntaxe de la formule à Google Sheets.

Vous ne trouvez pas le fichier téléchargé ? Vérifiez votre Google Drive personnel. C’est à cet emplacement que Smartsheet place vos exports.


Exporter vers Microsoft Project

Toute feuille comprenant un diagramme de Gantt peut être exportée au format Microsoft Project. Cette option n’est pas disponible pour les rapports.

  1. Ouvrez la feuille que vous souhaitez exporter.
  2. Dans la barre d’outils, basculez la feuille en Mode Gantt.
  3. Pour télécharger la feuille au format XML, sélectionnez Fichier > Exporter > Exporter vers MS Project.
  4. Pour importer le fichier XML, ouvrez Microsoft Project.

Étant donné que les fonctionnalités de Smartsheet et de Microsoft Project diffèrent, la feuille exportée peut s’afficher différemment dans les deux applications. Dans de tels cas, vous pouvez copier les données d’un programme et les coller dans l’autre en utilisant les raccourcis clavier Ctrl + C et Ctrl + V (Windows) ou Commande + C et Commande + V (MacOS).


Exporter en PDF

Pour exporter une feuille ou un rapport au format PDF, sélectionnez Fichier > Exporter > Exporter en PDF.

Lorsque vous exportez une feuille ou un rapport au format PDF, vous pouvez configurer sa disposition et choisir les colonnes à inclure.

Dans la section Options du formulaire Configuration du PDF, vous ne pouvez pas choisir les colonnes à inclure dans le fichier PDF si votre feuille ou rapport n’est pas en mode Gantt. Pour en savoir plus sur la création d’un PDF imprimable, consultez l’article d’aide Imprimer une feuille ou un rapport à partir de Smartsheet.