Jira connector: Jira version compatibility

Applies to

Smartsheet
  • Business
  • Enterprise

Capabilities

Who can use this capability

You must be a Sysadmin on Smartsheet and Jira to configure the connector. You must be a licensed Smartsheet user to create or edit a workflow. You'll also need a Jira account with access to your Jira project.

The Smartsheet connector for Jira is compatible only with specific versions of Jira Server and Data Center and Jira Cloud. 

Before you upgrade Jira, confirm the version you're installing is compatible with the connector. If you proceed with the upgrade, you do so at your own risk. 

As of August 2022, the following Jira versions are compatible with the Jira connector.

  • 6.x, 7.x, 8.x for Jira Server and Data Center
  • Jira Cloud

Version 9 is not supported and is not compatible with the Smartsheet Jira connector

Atlassian release notes