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Best Practices und Fehlerbehebung für Smartsheet Jira Connector

Smartsheet Jira Connector ist als Premium-Angebot erhältlich. Wenn Sie den Smartsheet Jira Connector für Ihren Plan erworben haben, melden Sie sich an, um Workflows zwischen Smartsheet und Jira zu erstellen.

Wer kann das nutzen?

Pläne:

  • Smartsheet Advance Package
  • Business
  • Enterprise

Berechtigungen:

Um einen Workflow zu erstellen oder zu bearbeiten, sind die folgenden Berechtigungen erforderlich:

  • Sie müssen ein lizenzierter Benutzer in der Smartsheet-Umgebung sein. Dies umfasst mindestens eine Bearbeiterberechtigung für Sheets, die dem Workflow zugeordnet sind.
  • Sie benötigen ein funktionales Jira-Konto mit entsprechenden Zugriffsrechten auf die Jira-Projekte, für die Sie einen Workflow erstellen möchten.
  • Ihr Systemadministrator muss die Einstellung „Restrict Users“ in Jira Connector aktivieren und Ihnen die Rolle „Smartsheet Jira Connector User“ zuweisen. Diese Rolle kann im Smartsheet Admin Center oder direkt auf der Oberfläche von Jira Connector zugewiesen werden.

Finden Sie heraus, ob diese Funktion in Smartsheet-Regionen oder Smartsheet Gov enthalten ist.

Synchronisierungsfehler suchen und beheben

Sie können folgende Ressourcen verwenden, um nach Workflow-Fehlern zu suchen und sie zu beheben:

  • Ausführungsverlauf: Gehen Sie zu dieser Seite, um die Anzahl der Synchronisierungsfehler für einen Workflow und die Fehlermeldung mit den Problemdetails zu sehen. 
  • Fehlerberichte: Wenn Probleme auftreten, erhält der Workflow-Inhaber und die Person, die das Feld oder die Workflow-Zeile bearbeitet hat, die das Problem verursacht hat, eine E-Mail.
  • Fehlerspalte: Überprüfen Sie diese Spalte in Ihrem Sheet, um eine Meldung zu Zeilen mit einem Synchronisierungsproblem zu überprüfen.

Run History

Nachdem Sie einen Workflow erstellt haben, können Sie auf die Run History Seite zugreifen, um den Synchronisierungsverlauf und etwaige Fehler anzuzeigen. Sie können auf die Run History zugreifen, indem Sie den Zeitstempel Ihres Workflows in Letzte Ausführung auswählen.

Brandfolder Image
Jira last run log

Es gibt die folgenden Ausführungstypen in Ihrem Run History:

  • Sync to Smartsheet: Workflow-Ausführungen für Änderungen aus Jira, die mit Smartsheet synchronisiert wurden.
  • Sync to Jira: Workflow-Ausführungen für Änderungen aus Smartsheet, die mit Jira synchronisiert wurden.
  • Filtered Row Finder: Workflow-Ausführungen für Änderungen an Problemen, die basierend auf Ihrer Workflow-Konfiguration herausgefiltert werden sollten. Filtered Row Finder ist ein Hintergrundprozess, der alle zwei Stunden ausgeführt wird. Herausgefilterte Probleme werden der Hierarchie Vom Connector herausgefiltert – nicht synchronisiert Ihres Sheets hinzugefügt. Der Filtered Row Finder Prozess wird nur für automatisierte Workflow-Typen ausgeführt. Dieser Prozess wird auch dann ausgeführt, wenn Sie keine Filter in Ihrem Workflow angegeben haben.

Fehler 

Wenn Probleme auftreten, erhält der Workflow-Inhaber und die Person, die das Problem verursacht hat, E-Mail-Fehlerberichte. Hier sind einige häufige Fehler und Probleme.

Feld „[Gruppe]“ nicht festgelegt

Betreff

Details

Mögliche Ursachen

Vorgänge ohne Gruppierungswert in Jira erscheinen in einer Hierarchie namens Feld „[Gruppe]“ nicht festgelegt.

Fehlerbehebung

Geben Sie den Vorgängen in Jira einen Gruppierungswert.

Vom Connector herausgefiltert – nicht synchronisiert

Betreff

Details

Mögliche Ursachen

Dies tritt mit dem Salesforce- und Jira-Connector auf. Die Vom Connector herausgefiltert – nicht synchronisiert Zeile fügt keine Zeilen mit Synchronisierungsproblemen hinzu, sondern nur Elemente, die in Salesforce gelöscht wurden oder Zeilen, die die Kriterien der Salesforce-Filter nicht mehr erfüllen und nicht mit Salesforce synchronisiert werden.

Fehlerbehebung

  • Wenn es Zeilen mit Fehlern oder Synchronisierungsproblemen gibt, sehen Sie einen Fehler im Feld Sync Error, der behoben werden muss, bevor die Zeile erfolgreich mit Salesforce synchronisiert wird.
  • Der Connector erstellt automatisch die Zeile Filtered Out by Connector-Not Synced, und alle Zeilen, die nicht synchronisiert werden, sind eingerückt darunter.

Häufig gestellte Fragen

Wenn Probleme auftreten, werden Fehlerberichte per E-Mail an den Workflow-Inhaber und die Person gesendet, die den Fehler/die Zeile im Workflow bearbeitet hat, der/die zu dem Problem geführt hat. Hier sind einige häufige Fehler und Probleme.

Problem: Zeilenreihenfolge ist nicht wie erwartet

Wenn Sie einen automatisierten Workflow ausführen, werden Probleme aufsteigend nach „Issue Key“ (Vorgangsschlüssel) sortiert, auch wenn sie in Jira anders sortiert sind. Um Probleme zu sortieren, die mit einem automatischen Workflow synchronisiert sind, verwenden Sie Row Grouping.

Bei manuellen Workflows wird der Prozess „Filtered Row Finder“ nicht ausgeführt. In diesem Fall können Sie die Zeilen in Ihrem Sheet manuell sortieren.

Wenn Sie Probleme manuell sortieren möchten, während Sie weiterhin einen automatisierten Workflow verwenden, gehen Sie wie folgt vor:

  1. Synchronisieren Sie Jira mit einem anderen Sheet.
  2. Verwenden Sie eine sheetübergreifende INDEX/MATCH- oder VLOOKUP-Formel, um die Werte mithilfe des „Issue Key“ in Ihr Hauptsheet zu übertragen. Beispielformel: =INDEX({Bereich mit zurückzugebendem Wert}, MATCH([Suchwert]@row, {Bereich mit Suchwert}, 0))

Error: Field '<field name>' cannot be set.<field name> It is not on the appropriate screen or is unknown.

Dieser Fehler wird angezeigt, wenn der festzulegende Feldwert nicht im Bildschirm „Edit“ von Jira angezeigt wird. Nur Felder im Bildschirm „Edit“ in Jira können über den Smartsheet Jira Connector bearbeitet werden.

Um dieses Problem zu beheben, führen Sie einen der folgenden Schritte aus:

  • Konfigurieren Sie den Bildschirm „Edit“ in Jira und fügen Sie das angegebene Feld zum Bildschirm hinzu. Weitere Informationen zu Jira-Bildschirmen, einschließlich der Schritte zur Änderung der Konfiguration, finden Sie in der Jira-Dokumentation unter Defining a Screen.
    -oder-
  • Ordnen Sie das angegebene Feld nur in eine Richtung zu, von Jira zu Smartsheet. Dadurch wird eine unidirektionale Zuordnung erstellt. Überarbeitungen an den Feldern in Smartsheet werden nicht in Jira übernommen.

Problem konnte nicht in Jira gespeichert werden

Sie benötigen Schreibberechtigungen für die verknüpften Jira-Projekte, um Daten darin zu speichern.

Daten werden nach Filteraktualisierungen nicht aus einem Sheet entfernt

Smartsheet wird keine Daten löschen, die aus Jira abgerufen wurden, da jede Zeile wichtige Spaltendaten, Anhänge oder Kommentare enthalten kann.
Wenn die Jira-Probleme in Ihrem Blatt die Kriterien des Workflow-Filters nicht mehr erfüllen, erstellt Smartsheet einen Abschnitt Filtered out by Connector—not synced oben, um die Informationen zu behalten, die der Connector herausfiltert. Sämtliche Zeilen, die herausgefiltert werden, werden erst dann synchronisiert, wenn sie die Filterkriterien wieder erfüllen. Und diese Zeilen können gelöscht werden, wenn Ihr Team sie nicht mehr im Sheet benötigt.

Fehler beim Aktualisieren einer Fehlerspalte in Smartsheet

Eine Fehlermeldung wird angezeigt, wenn Sie die Spalte „Synch.-Fehler“ aus dem verknüpften Sheet entfernen. Stellen Sie sicher, dass das Sheet die Spalte „Synch.-Fehler“ enthält, denn sie ist erforderlich. Sie können Ihren Workflow bearbeiten, um die Spalte „Synch.-Fehler“ wieder Ihrem Sheet zuzuordnen. Weitere Informationen finden Sie unter „Workflow ändern“.

Spalte „Fehler“

Diese Spalte wird vom Connector automatisch Ihrem Sheet hinzugefügt und enthält Details zu Synchronisierungsproblemen, die für die Zeile auftreten. 

 

..is not a valid user for the given JIRA project

Diese Nachricht kann angezeigt werden, wenn eine ungültige E-Mail-Adresse in ein mit Jira synchronisiertes Smartsheet-Feld eingegeben wird, was Probleme bei der Kontaktsynchronisierung verursachen kann. 

Zudem kann dieser Fehler in Jira Cloud auftreten, wenn der Benutzer dem Projekt in Jira nicht zugewiesen ist oder wenn externe Dienste (wie der Smartsheet Jira Connector) in Jira daran gehindert wurden, E-Mail-Adressen anzuzeigen. Eine benutzerspezifische Konfiguration kann geändert werden, indem Sie auf Profile > Manage your account > Profile and visibility zugreifen und die Einstellung Who can see this? ändern. für das Feld „Contact“ unten. Wenn diese Einstellung auf Only you and the admins festgelegt ist, kann der Jira Connector nicht auf die E-Mail-Adressinformationen des Benutzers mit dieser Einstellung zugreifen und das E-Mail-Feld wird nicht ausgefüllt.

Wenn ich versuche, auf den Jira Connector zuzugreifen, wird mir gesagt, dass ich nicht autorisiert bin, diese Aktion auszuführen. Was kann ich tun?

Es ist möglich, dass Sie noch nicht über die erforderlichen Berechtigungen verfügen, um auf den Jira Connector zuzugreifen. Wenden Sie sich an Ihren Smartsheet-Systemadministrator, um Unterstützung zu erhalten. 

Erfahren Sie how to contact your Sys Admin.