重大なプロファイル例外エラー

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FatalProfile 例外エラーは、通常、認証プロセス中に( Smartsheetに戻る前に)発生します。エラーはIdPからのものであることが多く、トラブルシューティングに使用する必要のない情報が多く含まれています。

このエラー リストには、最も一般的なエラーと、その原因となる問題を解決するためのヒントが含まれています。 

 

NameIDにはTextContentが必要です。

原因

  • アサーションで渡されるNameIDフィールドが空白です

解決策

  • キャプチャおよび分析アサーション。
  • クレームが正しく設定されていることを確認してください。
  • IdP管理者と提携して、NameIDフィールドが正しく設定されていることを確認してください。

アイデンティティプロバイダーのメタデータを見つけられませんでした。

原因

「あなたの会社アカウント」をクリックした後にこのエラーが発生し、IdP SSOページにリダイレクトされない場合、SAML設定 > IdPを編集 > IdPメタデータに入力されたIdPメタデータに期限切れのvalidUntil値が含まれている可能性があります。

Smartsheet(サービスプロバイダー)は、あなたのアイデンティティプロバイダーと通信できない可能性があります。これは、Smartsheetが「アイデンティティプロバイダーのメタデータを見つけられませんでした()」のURLエンドポイントに到達するのを妨げるファイアウォールの問題やその他のネットワークの問題である可能性があります。

URLが間違っている可能性もあります。

解決方法

無効なvalidUntil値があるかどうかを特定するには、IdP管理者と協力してメタデータを確認してください。 

CTRL+Fを使用して「validUntil」を検索します。validUntil値があり、その値の日付が過去である場合、IdPメタデータを修正し、その要素を削除する必要があります。Smartsheet > SAML設定 > IdPを編集 > IdPメタデータに移動して要素を削除できる場合があります。

このエラーを解決するには、Smartsheetがサインインプロセス中にアイデンティティプロバイダーと接続できる必要があり、Smartsheetが呼び出すエンドポイント/URLにはIdPメタデータが含まれている必要があります。

 

受信アサーションのセキュリティを確立できませんでした

原因

あなたのメタデータにアクセスできないか、検証できません。

  • アサーション内の509Certificateの値がSmartsheetに保存されているIdPメタデータの509Certificateの値と一致しません 

解決策

残念ながら、このエラーは多くの異なるシナリオによって引き起こされる可能性があります。確認すべきことがいくつかあります:

  • キャプチャおよび分析アサーション。
  • 組織の証明書とメタデータを確認してください。
  • 両方のメタデータ(Persistent ID/NameID)と(EmailAddress)を確認してください。
  • アサーション内の509Certificateの値がIdPメタデータに保存されているものと一致しない場合は、Smartsheetで更新できるように、IdPから新しいメタデータを取得する必要があります。

無効なHTTPメソッド(GET)

原因

  • 保存されたブラウザー設定がブロックしている可能性があります
  • メタデータパイプラインがブロックされている可能性があります

解決方法

  • キャッシュとCookieをクリアするか、InPrivateまたはシークレットのブラウザーセッションを試してください。
  • さらなる調査のためにSmartsheetサポートに連絡してください。

メッセージは署名されましたが、署名を検証できませんでした。

原因

  • ブラウザーに保存された設定
  • 証明書が期限切れまたは新しいものに切り替わりました
  • 証明書がSHA1を使用しています

解決方法

  • キャッシュとCookieをクリアしてください
  • 証明書が最近置き換えられたかどうかを確認してください。もしそうであれば、メタデータを更新 Smartsheetで。
  • 推奨されるSHA256証明書を使用するようにアップグレードしてください。

件名および属性情報を提供できません。属性マッピングに失敗しました: マッピングルックアップ 'DSX' が空の結果を返しました。

原因

  • IdPプロファイルのユーザーのプロファイルはまだ完全にプロビジョニングされていません

解決方法

  • キャッシュとCookieをクリアするか、InPrivateまたはシークレットのブラウザーセッションを試してください。
  • キャプチャおよび分析アサーション。
  • IdP管理者と協力して、ユーザーが完全に設定されていることを確認してください。影響を受けたユーザーを正常に動作しているユーザーと比較することは、この問題を理解するのに役立ちます。 

SAMLレスポンスがIdPエラーを報告しました

原因

  • ブラウザに保存された設定
  • IdP構成の証明書の変更がSmartsheetの更新なしに行われた
  • 必要なクレームがアサーションに存在しないか、間違った形式である

解決策

POSTで配信されたSAMLメッセージが不正なサーバーURLに送信されました

原因

  • これはおそらくIdPエラーです。SAMLメッセージがSPが実行されていると考える場所と矛盾する場所に宛てられると、このエラーが発生します。SPはこの情報の多くをWeb環境から取得します。

解決策

  • IdP管理者と協力して、メタデータを確認し、ACS URLが正しいことを確認してください。
  • 顧客のメタデータをSmartsheetにあるものと比較してください。必要に応じて、IdPからメタデータを直接再追加して、アプリに最新のバージョンがあることを確認してください。
  • レビュー Shibboleth Wiki.