適用対象

Smartsheet
  • Enterprise

重大なプロファイル例外エラー

ご利用可能なユーザー

プラン:

  • Enterprise

FatalProfile 例外エラーは、通常、認証プロセス中に( Smartsheetに戻る前に)発生します。エラーはIdPからのものであることが多く、トラブルシューティングに使用する必要のない情報が多く含まれています。

このエラー リストには、最も一般的なエラーと、その原因となる問題を解決するためのヒントが含まれています。 

 

NameID には テキストコンテンツ が必要です

原因

  • アサーションで渡される NameID フィールドは空白です

解決方法

  • アサーションをキャプチャおよび分析します。
  • クレームが正しく設定されていることを確認します。
  • IdP管理者と連携して、NameID フィールドが正しく設定されていることを確認します。

ID プロバイダーのメタデータが見つかりません

原因

「会社のアカウント」をクリックした後にこのエラーが表示され、 IdP SSOページにリダイレクトされないIdPは、 SAML設定""" IdP の編集""" IdPメタデータ期限切れの有効な期限値が含まれています。

Smartsheet (サービス プロバイダー)が ID プロバイダーと通信できない場合があります。ファイアウォールの問題またはその他のネットワークの問題が、 Smartsheetが「ID プロバイダー(ここに URL を挿入)" のメタデータが見つかりません」の URL エンドポイントにアクセスできない可能性があります。

また、URL が正しくない可能性もあります。

解決方法

無効な創設者(を通じて)の値があるかどうかを識別するには、 IdP管理者と協力してメタデータを確認します。 

Ctrl+F を使用して「有効期限」を検索します。有効な期限があり、その値の日付が過去の場合は、 IdPメタデータを変更してその要素を削除する必要があります。次に移動できる場合があります: Smartsheet """ SAML設定""" IdP の編集""" IdPメタデータ要素を削除します。

このエラーを解決するには、 Smartsheetをサインイン プロセス中に ID プロバイダーに接続できる必要があります。また、 Smartsheetが受け取るエンドポイント/URL にはIdPメタデータが含まれている必要があります。

 

受信アサーションのセキュリティを確立できません

原因

メタデータにアクセスできないか、検証できません。

  • アサーションの 509Certified 値が、 Smartsheetに保存されたIdPメタデータの 509Certified 値と一致しません

解決方法

残念ながら、このエラーはさまざまなシナリオによって発生する可能性があります。以下の点を確認してください。

  • アサーションをキャプチャおよび分析します。
  • 組織の証明書とメタデータを確認します。
  • (永続的な ID/NameID)と(EmailAddress)の両方のメタデータを確認します。
  • アサーションの 509Certified 値がIdPメタデータに保存されている内容と一致しない場合は、 Smartsheetで更新できるように、 IdPから新しいメタデータを取得する必要があります。

無効な HTTP メソッド(GET)

原因

  • 保存されたブラウザー設定が原因で、
  • メタデータ パイプラインがブロックされる可能性があります

解決方法

  • キャッシュと Cookie をクリアするか、InPrivate/シークレットのブラウザー セッションを試してみます。
  • さらなる調査が必要な場合は、 Smartsheetサポートまでお問い合わせください。

メッセージは署名されましたが、署名を検証できませんでした

原因

  • ブラウザーに保存された設定
  • 証明書が期限切れまたは新しい証明書にロールオーバーしました
  • 証明書では SHA1 を使用しています

解決方法

  • キャッシュと Cookie をクリア
  • 証明書が最近置換されたかどうかを確認します。その場合、メタデータを更新Smartsheetの "" です。
  • 提案された SHA256 証明書を使用するには、アップグレードしてください。

件名と属性情報を指定できません。属性のマッピングに失敗しました:マッピングの参照 "DSX" から、空の結果が返されました。

原因

  • IdPプロファイルのユーザー プロファイルがまだ完全にプロビジョニングされていない

解決方法

  • キャッシュと Cookie をクリアするか、InPrivate/シークレットのブラウザー セッションを試してみます。
  • アサーションをキャプチャおよび分析します。
  • IdP管理者と協力して、ユーザーが完全に設定されていることを確認します。影響を受けるユーザーと稼働中のユーザーを比較すると、この問題を理解するのに役立ちます。 

SAML応答でIdPエラーが報告されました

原因

  • Stored setting in browser
  • Smartsheetで更新を行わないIdP構成の証明書の変更
  • 必要なクレームがアサーションまたは誤った形式で存在していない

解決方法

  • キャッシュと Cookie をクリア
  • IdP管理者と協力して、変更が行われていないことを確認します。変更があった場合は、メタデータを更新Smartsheetの "" です。
  • アサーションをキャプチャおよび分析します。

正しくないサーバー URL への POST とともに送信されたSAMLメッセージ

原因

  • IdPエラーの可能性が高いです。SAMLメッセージが、SP によってメッセージが実行されていると推定されている場所と一致しない場所に向けられている場合、このエラーがスローされます。SP は、この情報の多くを Web 環境から引き出します。

解決方法

  • IdP管理者と協力してメタデータを確認し、ACS の URL を確認しますは正しいです。
  • 顧客のメタデータをSmartsheetのデータと比較します。必要に応じてIdPから直接メタデータを再追加して、アプリに最新バージョンを提供します。
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