Aplica-se a

Smartsheet
  • Enterprise

Erros de exceção de perfil fatal

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Plans:

  • Enterprise

Os Erros de Exceção de FatalProfile são normalmente fornecidos durante o processo de autenticação (antes de voltar ao Smartsheet). Os erros são mais comumente do IdP e contêm muitas informações que não precisamos usar para solucionar problemas.

Esta lista de erros inclui os erros mais comuns e dicas para resolver os problemas que os causam. 

 

NameID deve ter TextContent

Causa

  • O campo NameID que está sendo passado na afirmação está vazio

Resolução

  • Capture e analise uma asserção.
  • Verifique se as declarações estão configuradas corretamente.
  • Faça parceria com o IdP Admin para verificar se o campo NameID está configurado corretamente.

Impossível localizar os metadados do provedor de identidade

Causa

Se você receber esse erro depois de clicar em "Sua conta da empresa" e não for redirecionado para a página IdP SSO, é possível que os metadados IdP inseridos nas configurações SAML > Editar IdP > Metadados IdP incluam um valor validUntil expirado.

Smartsheet (o provedor de serviços) pode não conseguir se comunicar com seu provedor de identidade. Isso pode ser um problema de firewall ou outro problema de rede que impede que o Smartsheet atinja o ponto de extremidade da URL em "Impossível localizar metadados para o provedor de identidade ()."

Também é possível que o URL esteja incorreto.

Resolução

Para identificar se há um valor validUntil inválido, trabalhe com seu administrador do IdP para revisar seus metadados. 

Use CTRL+F para pesquisar "validUntil". Se houver um valor validUntil e a data desse valor estiver no passado, você precisará modificar seus metadados IdP e remover esse elemento. Você pode ir para Smartsheet > Configurações SAML > Editar IdP > Metadados IdP para remover o elemento.

Para resolver esse erro, o Smartsheet precisa ser capaz de se conectar ao Provedor de Identidade durante o processo de login e o ponto de extremidade/URL que as chamadas Smartsheet devem conter os metadados IdP.

 

Não foi possível estabelecer a segurança da afirmação recebida

Causa

Seus metadados não estão acessíveis ou não podem ser validados.

  • O valor 509Certificate na asserção não corresponde ao valor 509Certificate nos metadados IdP salvos no Smartsheet 

Resolução

Infelizmente, esse erro pode ser causado por muitos cenários diferentes. Confira abaixo algumas coisas para verificar:

  • Capture e analise uma asserção.
  • Verifique certificados e metadados para a organização.
  • Verifique os metadados para (ID persistente/NameID) e (EmailAddress).
  • Se o valor 509Certificate na afirmação não corresponder ao que você vê salvo nos metadados do IdP, será necessário obter novos metadados do IdP para poder atualizá-lo no Smartsheet.

Método HTTP inválido (GET)

Causa

  • As configurações do navegador armazenadas podem estar bloqueadas
  • O pipeline de metadados pode estar bloqueado

Resolução

  • Limpe o cache e os cookies ou tente uma sessão de navegador privada/anônima.
  • Entre em contato com o Suporte Smartsheet para obter mais informações.

A mensagem foi assinada, mas a assinatura não pôde ser verificada

Causa

  • Configuração armazenada no navegador
  • O certificado expirou ou foi transferido para um novo
  • O certificado está usando sha1

Resolução

  • Limpar cache e cookies
  • Determine se o certificado foi substituído recentemente. Em caso afirmativo, atualize seus metadados no Smartsheet.
  • Atualize para usar o certificado SHA256 sugerido.

Não foi possível fornecer informações de assunto e atributo. Falha no (s) mapeamento(s) de atributos: a pesquisa de mapeamento 'DSX' retornou um resultado vazio.

Causa

  • O perfil do usuário no perfil IdP ainda não está totalmente provisionado

Resolução

  • Limpe o cache e os cookies ou tente uma sessão de navegador privada/anônima.
  • Capture e analise uma asserção.
  • Trabalhe com o administrador IdP para confirmar que o usuário está completamente configurado. Comparar o usuário afetado com um usuário ativo pode ser útil para entender esse problema. 

Resposta SAML relatou um erro IdP

Causa

  • Stored setting in browser
  • Alteração de certificados na configuração do IdP sem uma atualização no Smartsheet
  • As reivindicações exigidas não estão presentes na afirmação ou em um formato incorreto

Resolução

  • Limpar cache e cookies
  • Trabalhe com o seu administrador de IdP para garantir que nenhuma alteração tenha ocorrido. Se houver alterações, atualize seus metadados no Smartsheet.
  • Capture e analise uma asserção.

Mensagem SAML entregue com POST para URL do servidor incorreto

Causa

  • Geralmente é um erro de IdP. Quando uma mensagem SAML é endereçada a um local inconsistente com o local em que a controladora acredita que está sendo executada, esse erro será exibido. O SP extrai grande parte dessas informações do ambiente da web.

Resolução

  • Trabalhe com o seu administrador do IdP para revisar seus metadados e verifique se o URL do ACS está correto.
  • Compare os metadados do seu cliente com o que está no Smartsheet. Adicione novamente os metadados diretamente do seu IdP, conforme necessário, para garantir que você tenha a versão mais atualizada do aplicativo.
  • Revise o Shibboleth Wiki.
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