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Los errores de excepción de perfil fatal se dan típicamente durante el proceso de autenticación (antes de volver a Smartsheet). Los errores provienen más comúnmente del IdP y contienen mucha información que no necesitamos usar para solucionar problemas.
Esta lista de errores incluye los errores más comunes y consejos para resolver los problemas que los causan.
NameID debe tener contenido de texto
No se puede localizar los metadatos para el proveedor de identidad
Causa
Si recibes este error después de hacer clic en "Tu cuenta de empresa" y no te redirige a la página de SSO del IdP, es posible que los metadatos del IdP ingresados en configuración de SAML > Editar IdP > Metadatos del IdP incluyan un valor validUntil expirado.
Smartsheet (el proveedor de servicios) puede no ser capaz de comunicarse con tu proveedor de identidad. Esto puede ser un problema de firewall u otro problema de red que impide que Smartsheet alcance el punto final de URL en "No se puede localizar metadatos para el proveedor de identidad (
También es posible que la URL sea incorrecta.
Resolución
Para identificar si hay un valor validUntil inválido, trabaja con tu administrador del IdP para revisar tus metadatos.
Usa CTRL+F para buscar “validUntil”. Si hay un valor validUntil, y la fecha de ese valor está en el pasado, entonces necesitarás modificar los metadatos de tu IdP y eliminar ese elemento. Es posible que puedas ir a Smartsheet > configuración de SAML > Editar IdP > Metadatos del IdP para eliminar el elemento.
Para resolver este error, Smartsheet necesita poder conectarse con el proveedor de identidad durante el proceso de inicio de sesión, y el punto final/URL que Smartsheet llama debe contener los metadatos del IdP.
No se pudo establecer la seguridad de la afirmación entrante
Causa
Tus metadatos no son accesibles o no pueden ser validados.
- El valor de 509Certificate en la afirmación no coincide con el valor de 509Certificate en los metadatos de IdP guardados en Smartsheet
Resolución
Desafortunadamente, este error puede ser causado por muchos escenarios diferentes. Aquí hay un par de cosas para verificar:
- Capturar y analizar una aserción.
- Verifique los certificados y metadatos de la organización.
- Verifique los metadatos para ambos (Persistent ID/NameID) y (EmailAddress).
- Si el valor de 509Certificate en la afirmación no coincide con lo que ve guardado en los metadatos de IdP, necesitará obtener nuevos metadatos de su IdP para poder actualizarlos en Smartsheet.
Método HTTP no válido (GET)
Causa
- La configuración del navegador almacenada podría estar bloqueando
- El pipeline de metadatos podría estar bloqueado
Resolución
- Borre la memoria caché y las cookies o intente abrir una sesión del navegador privada o de incógnito.
- Póngase en contacto con el soporte de Smartsheet para una investigación adicional.
El mensaje fue firmado, pero la firma no pudo ser verificada.
Causa
- Configuración almacenada en el navegador
- El certificado ha expirado o se ha cambiado por uno nuevo
- El certificado está utilizando SHA1
Resolución
- Borre la memoria caché y las cookies
- Determine si el certificado fue reemplazado recientemente. Si es así, actualice sus metadatos en Smartsheet.
- Actualice para usar el certificado SHA256 sugerido.
No se puede proporcionar información sobre el sujeto y los atributos. Falló el mapeo de atributos: la búsqueda de mapeo 'DSX' devolvió un resultado vacío.
Causa
- El perfil del usuario en el perfil del IdP no está completamente provisionado aún
Resolución
- Borre la memoria caché y las cookies o intente abrir una sesión del navegador privada o de incógnito.
- Capturar y analizar una aserción.
- Trabaje con el administrador del IdP para confirmar que el usuario esté completamente configurado. Comparar el usuario afectado con un usuario que funcione puede ser útil para entender este problema.
La respuesta SAML informó un error del IdP
Causa
- Ajuste almacenado en el navegador
- Cambio en los certificados en la configuración del IdP sin una actualización en Smartsheet
- Los reclamos requeridos no están presentes en la aserción o están en un formato incorrecto
Resolución
- Borre la memoria caché y las cookies
- Trabaje con su administrador del IdP para asegurarse de que no se hayan producido cambios. Si ha habido cambios, actualice su metadatos en Smartsheet.
- Capturar y analizar una aserción.
Mensaje SAML entregado con POST a URL de servidor incorrecta
Causa
- Esto es muy probablemente un error del IdP. Cuando un mensaje SAML se dirige a una ubicación inconsistente con donde el SP cree que está funcionando, se lanzará este error. El SP obtiene gran parte de esta información del entorno web.
Resolución
- Trabaje con su administrador del IdP para revisar sus metadatos y asegurarse de que la URL de ACS sea correcta.
- Compare los metadatos de su cliente con lo que hay en Smartsheet. Vuelve a agregar los metadatos directamente desde tu IdP según sea necesario para asegurarte de tener la versión más actualizada en la aplicación.
- Revisa el Wiki de Shibboleth.