Answers to the most commonly asked Calendar App questions.
Calendar App FAQs
Who can use this capability?
- If Calendar App is part of your plan, you can use it.
- Anyone shared to the calendar can create and edit their private filters.
- Anyone can access the Calendar App after someone has shared a calendar to them or if an administrator on their account has given them access to the application.
What's the difference between the Calendar App and Calendar View?
The Smartsheet Calendar App is a Premium add-on that exists outside of the Smartsheet app. Calendar view is a drop-down option in the sheet view options. Here are the differences between Calendar App and Calendar View:
1. Only the month view is available in the calendar view. Smartsheet users can only view their sheets in a monthly view when they switch to the calendar view. In the Calendar App, users can choose from multiple views such as, day, week, multi-month, and quarter.
2. Must share or publish the sheet to view. Users must share or publish their entire sheet to share the calendar view with their team. If you have sensitive data in the underlying sheet that you do not want others to view, this option may not work.
3. Categories for grouping events and custom color codes. Users can easily create categories to group events and choose custom colors using hex codes. You can only group in a calendar view by using conditional formatting to color-code types of events.
Does the new Admin of a calendar need to log into the calendar app before you can transfer calendars to them?
Yes, this limitation remains true. A user must log into Calendar App at least once at any point in time to receive a calendar transfer.
What does the column definition option in sorting mean?
This option is sorted based on how you define column options. If you had a picklist column with options C, A, B input that would be the sort order.
Is there an easy way to put holidays in the calendar?
No, there's no current way to let the calendar know about holidays natively. You have to treat the dates as regular events in your sheet and pull them in.
Can Calendar App use multiple sheets? Can it be grouped by categories?
You can create a calendar based on a report and use two grouping levels on the left side of the settings view to arrange by training and region.
Can you choose different colors on the calendar app view?
In the data grouping section, select any category or subcategory groupings you’d like to use. Selecting categories makes the items appearing on the calendar appear as specific collections. These groups appear on the left side of the calendar and drive the color coding in your calendar.
Can you view which sheet a calendar view is linked to after the calendar view is saved?
Yes, in the calendar settings, on the 7-Confirm page, you see the name of the sheet/report that is the source.
Why can't I edit start or end dates in the Calendar App?
You can edit the start and end dates if the column is not a formula, cell link, system value, or locked column.
Why is my new category value not showing up in the calendar?
If you add a new category value in Smartsheet, you need to refresh the Custom Category List Order so that it shows up in the calendar.
Why don’t I see the Add New button on Calendar home page?
If you do not see the Add New button on the calendar home page, reach out to your organization's System Admin to ensure you are a member on your organization's plan.
Can users only edit content if they are shared with source sheets and reports?
Users can only edit if they have editing rights to the source sheet or report for that calendar.
I get an error icon next to a filter name. You may see the calendar name greyed out with an Error icon for calendars that you own.
Cause
The filter definition is no longer valid. There are a few reasons why a filter definition is no longer valid:
- The column is no longer part of the calendar definition.
- The column type has changed.
- Filtering criteria are no longer available for the column type.
Troubleshooting Steps/Resolution
- Select the Edit icon to open the filter form to see the exact reason for the error.
- Then, either fix the filter definition or delete the filter.
- If a shared filter has an error message, the owner must update it.
I get an error when trying to confirm current admin or entering a new admin
Cause
- The email provided isn't valid.
- The Admin is not in the same organization.
- Internal server error.
Troubleshooting Steps/Resolution
Make the suggested fix the error message provides.
I get an error when trying to select calendars
Cause
The user isn't an Admin on any of the calendars they try to select.
Troubleshooting Steps/Resolution
Make the suggested fix the error message provides.
Failure during calendar transfer
Cause
- The new Admin doesn't have sufficient permissions. They must be an Admin on the calendar's source sheet or report.
- Calendar not found.
- You can’t transfer the calendar to the same email.
- The new Admin user wasn’t found. The new Admin must be an Admin on the calendar's source sheet or report.
- Internal server error. Please try again later.
Troubleshooting Steps/Resolution
Make the suggested fix the error message provides.
I'm an admin on the underlying sheet, why can’t I see the Calendar in my list view?
The calendar only shows up in the list view for the Primary Admin if sharing is toggled off. If sharing is toggled on, then the calendar will appear in the list view for all users who are calendar admins or added on the calendar share list. Learn more about sharing your calendar.