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Best Practices und Fehlerbehebung für Smartsheet Jira Connector

Smartsheet Jira Connector ist als Premium-Angebot erhältlich. Wenn Sie Smartsheet Jira Connector für Ihren Plan erworben haben, melden Sie sich an, um Workflows zwischen Smartsheet und Jira zu erstellen.

Wer kann das nutzen?

Pläne:

  • Smartsheet Advance Package
  • Business
  • Enterprise

Berechtigungen:

Um einen Workflow zu erstellen oder zu bearbeiten, sind die folgenden Berechtigungen erforderlich:

  • Sie müssen ein lizenzierter Benutzer in der Smartsheet-Umgebung sein. Dies umfasst mindestens eine Bearbeiterberechtigung für Sheets, die dem Workflow zugeordnet sind.
  • Sie benötigen ein funktionales Jira-Konto mit entsprechenden Zugriffsrechten auf die Jira-Projekte, für die Sie einen Workflow erstellen möchten.
  • Ihr Systemadministrator muss die Einstellung „Restrict Users“ in Jira Connector aktivieren und Ihnen die Rolle „Smartsheet Jira Connector User“ zuweisen. Diese Rolle kann im Smartsheet Admin Center oder direkt auf der Oberfläche von Jira Connector zugewiesen werden.

Finden Sie heraus, ob diese Funktion in Smartsheet-Regionen oder Smartsheet Gov enthalten ist.

Synchronisierungsfehlern suchen und beheben

Sie können folgende Ressourcen verwenden, um nach Workflow-Fehlern zu suchen und sie zu beheben:

  • Run History (Ausführungsverlauf): Auf dieser Seite werden die Anzahl von Synchronisierungsfehlern für einen Workflow sowie die Fehlermeldung mit den Problemdetails angezeigt. 
  • Fehlerberichte: Im Falle von Problemen wird eine E-Mail an den*die Workflow-Inhaber*in sowie an die Person gesendet, die das Feld oder die Workflow-Zeile bearbeitet hat, auf das bzw. auf die das Problem zurückzuführen ist.
  • Fehlerspalte: Diese Spalte in Ihrem Sheet enthält Meldungen zu Zeilen mit einem Synchronisierungsproblem.

Run History

Nachdem Sie einen Workflow erstellt haben, werden auf der Seite „Run History“ der Synchronisierungsverlauf und etwaige Fehler angezeigt. Sie können auf „Run History“ zugreifen, indem Sie den Zeitstempel unter „Ausführungsdatum“ für Ihren Workflow auswählen.

Brandfolder Image
Jira last run log

Unter „Run History“ werden die folgenden Ausführungstypen angezeigt:

  • Sync to Smartsheet: Workflow-Ausführungen für Änderungen aus Jira, die mit Smartsheet synchronisiert wurden
  • Sync to Jira: Workflow-Ausführungen für Änderungen aus Smartsheet, die mit Jira synchronisiert wurden
  • Filtered Row Finder: Workflow-Ausführungen für Änderungen an Problemen, die basierend auf Ihrer Workflow-Konfiguration herausgefiltert werden sollten. „Filtered Row Finder“ ist ein Hintergrundprozess, der alle zwei Stunden ausgeführt wird. Herausgefilterte Probleme werden der Hierarchie Vom Connector herausgefiltert – nicht synchronisiert Ihres Sheets hinzugefügt. Der Prozess von „Filtered Row Finder“ wird nur für automatisierte Workflow-Typen ausgeführt. Dieser Prozess wird auch dann ausgeführt, wenn Sie keine Filter in Ihrem Workflow angegeben haben.

 


Fehler?

Wenn Probleme auftreten, werden Fehlerberichte per E-Mail an den Workflow-Inhaber und die Person gesendet, die den Fehler/die Zeile im Workflow bearbeitet hat, der/die zu dem Problem geführt hat. Hier sind einige häufige Fehler und Probleme.

Feld „[Gruppe]“ nicht festgelegt

Betreff

Details

Mögliche Ursachen

Vorgänge ohne Gruppierungswert in Jira werden in eine Hierarchie namens Field [Group] not set (Feld „[Gruppe]“ nicht festgelegt) platziert.

Fehlerbehebung

Geben Sie Problemen in Jira einen Gruppierungswert

Vom Connector herausgefiltert – nicht synchronisiert

Betreff

Details

Mögliche Ursachen

Diese Funktion wird mit dem Salesforce- und Jira-Connector ausgeführt. Die Zeile „Vom Connector herausgefiltert – nicht synchronisiert“ fügt keine Zeilen mit Synchronisierungsproblemen hinzu, sondern nur Elemente, die in Salesforce gelöscht wurden, oder Zeilen, die die Salesforce-Filterkriterien nicht mehr erfüllen und nicht mit Salesforce synchronisiert werden.

Fehlerbehebung

  • Wenn es Zeilen mit Fehlern oder Synchronisierungsproblemen gibt, wird im Feld Sync Error (Synchronisierungsfehler) ein Fehler angezeigt, der behoben werden muss, bevor die Zeile erfolgreich mit Salesforce synchronisiert wird.
  • Der Connector erstellt automatisch die Zeile „Vom Connector herausgefiltert – nicht synchronisiert“. Alle Zeilen, die nicht synchronisiert werden, werden unten eingerückt.

FAQ

Wenn Probleme auftreten, werden Fehlerberichte per E-Mail an den Workflow-Inhaber und die Person gesendet, die den Fehler/die Zeile im Workflow bearbeitet hat, der/die zu dem Problem geführt hat. Hier sind einige häufige Fehler und Probleme.

Problem: Zeilenreihenfolge ist nicht wie erwartet

Wenn Sie einen automatisierten Workflow ausführen, werden Probleme aufsteigend nach „Issue Key“ (Vorgangsschlüssel) sortiert, auch wenn sie in Jira anders sortiert sind. Verwenden Sie Row Grouping, um Probleme zu sortieren, die mit einem automatischen Workflow synchronisiert werden.

Bei manuellen Workflows wird der Prozess „Filtered Row Finder“ nicht ausgeführt. In diesem Fall können Sie die Zeilen in Ihrem Sheet manuell sortieren.

Wenn Sie Probleme manuell sortieren möchten, während Sie weiterhin einen automatisierten Workflow verwenden, gehen Sie wie folgt vor:

  1. Synchronisieren Sie Jira mit einem anderen Sheet.
  2. Verwenden Sie eine Sheet-übergreifende INDEX/MATCH- oder VLOOKUP-Formel, um die Werte mithilfe des „Issue Key“ in Ihr Haupt-Sheet zu übertragen. Beispielformel: =INDEX({Bereich mit zurückzugebendem Wert}, MATCH([Suchwert]@row, {Bereich mit Suchwert}, 0))

Error: Field '<field name>' cannot be set.<field name> It is not on the appropriate screen or is unknown.

Dieser Fehler wird angezeigt, wenn der festzulegende Feldwert nicht im Bildschirm „Edit“ von Jira angezeigt wird. Nur Felder im Bildschirm „Edit“ in Jira können über den Smartsheet Jira Connector bearbeitet werden.

Um dieses Problem zu beheben, führen Sie einen der folgenden Schritte aus:

  • Konfigurieren Sie den Bildschirm „Edit“ in Jira und fügen Sie das angegebene Feld zum Bildschirm hinzu. Weitere Informationen zu Jira-Bildschirmen, einschließlich der Schritte zur Änderung der Konfiguration, finden Sie in der Jira-Dokumentation unter Defining a Screen.
    -oder-
  • Ordnen Sie das angegebene Feld nur in eine Richtung zu, von Jira zu Smartsheet. Dadurch wird eine unidirektionale Zuordnung erstellt. Überarbeitungen an den Feldern in Smartsheet werden nicht in Jira übernommen.

Problem konnte nicht in Jira gespeichert werden

Sie benötigen Schreibberechtigungen für die verknüpften Jira-Projekte, um Daten darin zu speichern.

Daten werden nach Filteraktualisierungen nicht aus einem Sheet entfernt

Smartsheet löscht keine Daten, die Sie aus Jira abgerufen haben, da jede Zeile wichtige Spaltendaten, Anlagen oder Kommentare enthalten kann.
Wenn die Jira-Probleme in Ihrem Sheet die Workflow-Filterkriterien nicht mehr erfüllen, erstellt Smartsheet oben den Abschnitt Vom Connector herausgefiltert – nicht synchronisiert, um die vom Connector herausgefilterten Informationen beizubehalten. Sämtliche Zeilen, die herausgefiltert werden, werden erst dann synchronisiert, wenn sie die Filterkriterien wieder erfüllen. Und diese Zeilen können gelöscht werden, wenn Ihr Team sie nicht mehr im Sheet benötigt.

Fehler beim Aktualisieren einer Fehlerspalte in Smartsheet

Eine Fehlermeldung wird angezeigt, wenn Sie die Spalte „Synch.-Fehler“ aus dem verknüpften Sheet entfernen. Stellen Sie sicher, dass das Sheet die Spalte „Synch.-Fehler“ enthält, denn sie ist erforderlich. Sie können Ihren Workflow bearbeiten, um die Spalte „Synch.-Fehler“ wieder Ihrem Sheet zuzuordnen. Weitere Informationen finden Sie unter „Workflow ändern“.

Spalte „Fehler“

Diese Spalte wird vom Connector automatisch Ihrem Sheet hinzugefügt und enthält Details zu Synchronisierungsproblemen, die für die Zeile auftreten. 

 

..is not a valid user for the given JIRA project

Diese Nachricht kann angezeigt werden, wenn eine ungültige E-Mail-Adresse in ein Smartsheet-Feld eingegeben wird, das mit Jira synchronisiert wird, und kann Probleme bei der Kontaktsynchronisierung verursachen. 

Zudem kann dieser Fehler in Jira Cloud auftreten, wenn der Benutzer dem Projekt in Jira nicht zugewiesen ist oder wenn externe Services (wie Smartsheet Jira Connector) in Jira daran gehindert wurden, E-Mail-Adressen anzuzeigen. Eine benutzerspezifische Konfiguration kann geändert werden, indem Sie auf Profile > Manage your account > Profile and visibility zugreifen und die Einstellung Who can see this? für das Feld „Contact“ unten ändern. Wenn diese Einstellung auf Only you and the admins festgelegt ist, kann Jira Connector nicht auf die E-Mail-Adressinformationen des Benutzers mit dieser Einstellung zugreifen und das E-Mail-Feld wird nicht ausgefüllt.