Error: Google SSO failed 403

Applies to

Smartsheet

Symptom

Google SSO failed 403 "Error: app_not_enabled_for_user

After setting up SAML with Google as the IdP users receive the error message:

Cause

User access to the app has not been enabled.

Resolution

Steps to resolve can be found in Google article for all SAML error messages https://support.google.com/a/answer/6301076?hl=en

  1. From the Admin console Home page, go to AppsWeb and mobile apps.
  2. In the app list, locate the SAML app generating the error.
  3. Click the app to open its Settings page.
  4. Click User access.
  5. Enable the app.